Hyundai Coupe Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, I currently own a 56 Reg Hyundai coupe SIII. The Ipod interface has stopped working 4 times in the past 8 months. I have taken it to my local Hyundai dealer (SG PETCH In middlesbrough) everytime to be repaired. After i get it back it usually works for a few month and then just cuts out again. I had it in again last week to be repaired, 2 days later its broken again. The Ipod is a standard 4Gig Ipod that i bought last year. The Ipod works with other devices, The stereo just seems to stop picking it up, as though its no longer connected. Any ideas whats wrong or what I can do to get this sorted??? Im getting sick of taking it to the garage! Apart from this my Hyundai coupe is A great car and I have never had any other problems or complaints about it.

Thanks

Ste
 

·
Premium Member
Joined
·
7,563 Posts
have you asked the garage when you take it in what the problem was? it may help you figure a way to avoid it. I've never heard of this being a common fault.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Yeah i asked them everytime. The first time they said it was just a loose wire. The second time they said they couldnt find anything wrong and they didnt understand why it wasnt working so they just reset it and it was fine. The third time they said they replaced the interface. They obviousely didnt because it stopped working again 2 days later.
 

·
Registered
Joined
·
198 Posts
take it back and demand an aftermarket head unit replacement,

then if they say no we have to replace it like for like ask for the serial of the old one and the new one,

if it stops working again tell them your going to consult legal advice about trading standards.

id be tempted to use trading standards as my first choice to be quite honnest.

is it under warrenty ?
 
1 - 5 of 5 Posts
Top