Hyundai Coupe Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter · #1 ·
was just wondering for anybody with a big size stereo has anybody uprated their alternator to a bigger version? i have a coupe alternator on my accent which is a 90 amp compared to my old 80 amp but im still dropping voltage when running the car and having the stereo up for example at meets and shows. So was just wondering if anybody had uprated theirs and if so to what and where did you get it from?
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #3 ·
im running 2 exide deep cycle batteries with a split charge system but ive had this problem ever since having the system fitted due to the power its running i think and the alternator just isnt up to the job really it really needs a high amp alt.
 

·
Premium Member
Joined
·
7,563 Posts
2's not that many for a loud spl system to be honest, more batteries will allow more power to be stored meaning the alternator wont have as much trouble keeping them topped up
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #5 ·
i would think that 2 batteries would be fine for 1000W RMS as its not that much compared to these audio cars, it does run fine with no problems really but i just dont like the fact that the voltage drops even when running it should stay at 14v but can drop to below 11v on long time when playing at a loud level.
 

·
Registered
Joined
·
73 Posts
Discussion Starter · #7 ·
i have a momo alpine 1000W RMS amp powering my 2 alpine type r subs running at 500W RMS plus i have a 4 channel amp running my 2 6x9s in rear quarters and components speakers up front that amp is 100W RMS per channel and all speakers are 95W RMS or 100W RMS

see
 

·
Registered
Joined
·
2,562 Posts
Im running over 1000 RMS on the standard battery...
Really need to sort that out :oops:
 
1 - 9 of 9 Posts
Top